Linux jexus service is set to boot
This article is for you to share the specific code of jexus service setup boot startup for your reference, the specific contents are as follows
Generally speaking, the service boot configuration of linux is in / etc/init.d/.
The default installation directory of jexus is / usr/jexus. The startup file is jws and the parameter start stop restart.
Here is a newly written startup script for jexus
#! / bin/bash### BEGIN INIT INFO## Provides: jws# Required-Start: $local_fs $remote_fs# Required-Stop: $local_fs $remote_fs# Default-Start: 2 34 "Default-Stop: 0 1" Short-Description: jws# Description: This file should be used to construct scripts to be placed in/ etc/init.d.#### END INIT INFO## Fill in name of program here.PROG= "jws" PROG_PATH= "/ usr/jexus" # # Not need But sometimes helpful (if $PROG resides in / opt for example). PROG_ARGS= "start" PID_PATH= "/ var/run/" start () {if [- e "$PID_PATH/$PROG.pid"] Then # # Program is running, exit with error. Echo "Error! $PROG is currently running!" 1 > & 2 exit 1 else # # Change from / dev/null to something like / var/log/$PROG if you want to save output. $PROG_PATH/$PROG $PROG_ARGS 2 > & 1 > / var/log/$PROG & $pid= `ps ax | grep-I 'jws' | sed's / ^\ ([0-9]\ {1,\}\). * /\ 1echo g'| head-n 1`echo "$PROG started" echo $pid > "$PID_PATH/$PROG.pid" fi} stop () {echo "begin stop" if [- e "$PID_PATH/$PROG.pid"] Then # # Program is running, so stop it pid= `ps ax | grep-I 'jws' | sed's / ^\ ([0-9]\ {1,\}\). * /\ 1DB g' | head-n 1` kill $pid rm-f "$PID_PATH/$PROG.pid" echo "$PROG stopped" else # # Program is not running, exit with error. Echo "Error! $PROG not started!" 1 > & 2 exit 1fi} # # Check to see if we are running as root first.## Found at http://www.cyberciti.biz/tips/shell-root-user-check-script.htmlif ["$(id-u)"! = "0"]; then echo "This script must be run as root" 1 > & 2 exit 1ficase "$1" in start) start exit 0; stop) stop exit 0;; restart) stop start exit 0 * *) echo "Usage: $0 {start | stop | restart}" 1 > & 2 exit 1;; esac
Last remember sudo chmod + x / etc/init.d/jws
Add Auto start Service sudo update-rc.d jws defaults
Delete the auto-startup service sudo update-rc.d jws remove
The above is the whole content of this article, I hope it will be helpful to your study, and I also hope that you will support it.