How to install and deploy Hadoop2.6+jdk8 using the jar package
In addition, you can see which files are on hdfs:
The method is to click Browse the file system in the menu Utilities above
(the blog of HappyBKs, a user of oschina at the beginning of this article, please reprint it in a conspicuous position to state the source! Http://my.oschina.net/u/1156339/blog/396128)
So now, let's try to add directories and files to hdfs.
[neil@neilhost hadoop-2.6.0] $bin/hadoop fs-mkdir / myhome [neil@neilhost hadoop-2.6.0] $bin/hadoop fs-mkdir / myhome/happyBKs [neil@neilhost hadoop-2.6.0] $
Look at the Browse the file system in Utilities again.
Next, let's try to add a file.
Here, I add two files and an entire folder at once.
[neil@neilhost hadoop-2.6.0] $bin/hadoop fs-put README.txt NOTICE.txt logs/ / myhome/happyBKs
Let's look at hdfs.
6. We have started dfs in the first 5. Start yarn now. Unlike dfs, yarn does not have a direct impact on data. We can start it once, or we can use yarn-daemon.sh start resourcemanager and yarn-daemon.sh start nodemanager under sbin to start it respectively.
Here I start directly at once, using start-yarn.sh
[neil@neilhost hadoop-2.6.0] $sbin/start-yarn.sh starting yarn daemonsstarting resourcemanager, logging to / home/neil/Servers/hadoop-2.6.0/logs/yarn-neil-resourcemanager-neilhost.neildomain.outlocalhost: ssh: connect to host localhost port 22: Connection refused [neil@neilhost hadoop-2.6.0] $sudo sbin/start-yarn.sh [sudo] password for neil: starting yarn daemonsstarting resourcemanager Logging to / home/neil/Servers/hadoop-2.6.0/logs/yarn-root-resourcemanager-neilhost.neildomain.outlocalhost: ssh: connect to host localhost port 22: Connection refused [neil@neilhost hadoop-2.6.0] $
As you can see, the startup is denied here because ssh access is denied. It's the same even if I use su permission.
Sudo yum install openssh-server
Several solutions on ubuntu are given on the Internet.
Http://asyty.iteye.com/blog/1440141 http://blog.sina.com.cn/s/blog_573a052b0102dwxn.html
As a result, they all failed after input.
/ etc/init.d/ssh-start
Bash: / etc/init.d/ssh: there is no such file or directory
Net start sshd
Invalid command: net start
The final solution:
[neil@neilhost hadoop-2.6.0] $service sshd startRedirecting to / bin/systemctl start sshd.service [neil@neilhost hadoop-2.6.0] $pstree-p | grep ssh |-sshd (7937) [neil@neilhost hadoop-2.6.0] $ssh locahostssh: Could not resolve hostname locahost: Name or service not known [neil@neilhost hadoop-2.6.0] $ssh localhostThe authenticity of host 'localhost (127.0.0.1)' can't be established.ECDSA key Fingerprint is 88:17:a4:f2:dd:87:6f:ce:b4:04:07:d5:6c:ca:6c:b1.Are you sure you want to continue connecting (yes/no)? YPlease type 'yes' or' no': yesWarning: Permanently added 'localhost' (ECDSA) to the list of known hosts.neil@localhost's password: [neil@neilhost ~] $
After that, we try to start yarn again.
[neil@neilhost hadoop-2.6.0] $sbin/start-yarn.shstarting yarn daemonsresourcemanager running as process 5115. Stop it first.neil@localhost's password: localhost: starting nodemanager, logging to / home/neil/Servers/hadoop-2.6.0/logs/yarn-neil-nodemanager-neilhost.neildomain.out [neil@neilhost hadoop-2.6.0] $jps [neil@neilhost hadoop-2.6.0] $jps10113 Jps7875 NameNode9974 NodeManager8936 ResourceManager8136 DataNode8430 SecondaryNameNode
It was found that ResourceManager was officially launched. (here, because I didn't write this article in a day, the pid will be different.)
At this point, we type yarn001:8088. Enter the UI below. Just enter the Active Node may be 0, wait for a period of time to refresh will appear 1.
Note: if always 0, use jps to see if nodemanager has been started, and if not, try it with sbin/start-yarn.sh start nodemanager.
These are all the contents of the article "how to install and deploy Hadoop2.6+jdk8 using the jar package". Thank you for reading! I believe we all have a certain understanding, hope to share the content to help you, if you want to learn more knowledge, welcome to follow the industry information channel!