What about the python compress command not found error when installing the kilo version of openstack-dashboard
Editor to share with you the installation of kilo version of openstack-dashboard python compress command not found errors how to do, I hope you will learn something after reading this article, let's discuss it together!
Solutions to python compress command not found errors when installing openstack-dashboard
Failed to start the httpd service
# systemctl status httpd ● httpd.service-The Apache HTTP Server Loaded: loaded (/ usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled) Drop-In: / usr/lib/systemd/system/httpd.service.d └─ openstack-dashboard.conf Active: failed (Result: exit-code) since Fri 2016-10-14 16:13:27 CST 25s ago Docs: man:httpd (8) man:apachectl (8) Process: 86591 ExecStartPre=/usr/bin/python / usr/share/openstack-dashboard/manage.py compress-- force (code=exited, status=1/FAILURE) Process: 86581 ExecStartPre=/usr/bin/python / usr/share/openstack-dashboard/manage.py collectstatic-- noinput-- clear (code=exited, status=0/SUCCESS) Main PID: 82651 (code=exited Status=0/SUCCESS) Oct 14 16:13:27 bdc2 python [86591]: CommandError: An error occurred during rendering / usr/share/openstack-dashboard/openstack_dashboard/templates/_stylesheets.html: / bin/sh: django_pyscss.compressor.DjangoScssFilter: command not foundOct 14 16:13:27 bdc2 python [86591]: Found 'compress' tags in:Oct 14 16:13:27 bdc2 python [86591]: / usr/lib/python2.7/site-packages/horizon/templates/horizon/_conf.htmlOct 14 16: 13:27 bdc2 python [86591]: / usr/share/openstack-dashboard/openstack_dashboard/templates/_stylesheets.htmlOct 14 16:13:27 bdc2 python [86591]: / usr/lib/python2.7/site-packages/horizon/templates/horizon/_scripts.htmlOct 14 16:13:27 bdc2 python [86591]: Compressing...Oct 14 16:13:27 bdc2 systemd [1]: httpd.service: control process exited Code=exited status=1Oct 14 16:13:27 bdc2 systemd [1]: Failed to start The Apache HTTP Server.Oct 14 16:13:27 bdc2 systemd [1]: Unit httpd.service entered failed state.Oct 14 16:13:27 bdc2 systemd [1]: httpd.service failed.
The execution of a failed command in the above state will result in a specific error message
# / usr/bin/python / usr/share/openstack-dashboard/manage.py compress-- forceFound 'compress' tags in: / usr/lib/python2.7/site-packages/horizon/templates/horizon/_conf.html / usr/share/openstack-dashboard/openstack_dashboard/templates/_stylesheets.html / usr/lib/python2.7/site-packages/horizon/templates/horizon/_scripts.htmlCompressing... CommandError: An error occurred during rendering / usr/share/openstack-dashboard/openstack_dashboard/templates/_stylesheets.html: / bin/sh: django_pyscss.compressor.DjangoScssFilter: command not found
Error analysis: python-django cannot execute the command of compress and modify the compress in the file according to the saying on the Internet
{% load compress%} {% compress css%} {% endcompress%}
Change type='text/scss' to type='text/x-scss' or type='text/css', and restart the httpd service. The service still fails to start or can start successfully, but the check status still shows an exception.
Correct solution: modify the version of django-pyscss so that version 2.0.2 can use the default installation, the source in epel will be installed automatically, version 1.0.5
# yum list | grep django-pyscsspython-django-pyscss.noarch 1.0.5-2.el7 @ epel # cd / usr/lib/python2.7/site-packages/# ls | grep pyscssdjango_pyscssdjango_pyscss-1.0.5-py2.7.egg-info
Remove version 1.0.5 and install version 2.0.2 using pip
# cd / usr/lib/python2.7/site-packages/# mv django_pyscss-1.0.5-py2.7.egg-info django_pyscss-1.0.5-py2.7.egg-info_bak# pip install django-pyscss==2.0.2# pip list | grep pyscssdjango-pyscss (2.0.2)
Restart the httpd service
# systemctl restart httpd# systemctl status httpd ● httpd.service-The Apache HTTP Server Loaded: loaded (/ usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled) Drop-In: / usr/lib/systemd/system/httpd.service.d └─ openstack-dashboard.conf Active: active (running) since Fri 2016-10-14 16:40:52 CST 27min ago Docs: man:httpd (8) man:apachectl (8) Process: 89942 ExecStop=/bin/kill-WINCH ${MAINPID} (code=exited, status=0/SUCCESS) Process: 90015 ExecStartPre=/usr/bin/python / usr/share/openstack-dashboard/manage.py compress-force (code=exited, status=0/SUCCESS) Process: 90007 ExecStartPre=/usr/bin/python / usr/share/openstack-dashboard/manage.py collectstatic-- noinput-- clear (code=exited Status=0/SUCCESS) Main PID: 90044 (httpd) Status: "Total requests: 81 Current requests/sec: 0 Current traffic: 0 B/sec "CGroup: / system.slice/httpd.service ├─ 90044 / usr/sbin/httpd-DFOREGROUND ├─ 90046 / usr/sbin/httpd-DFOREGROUND ├─ 90047 (wsgi:keystone--DFOREGROUND ├─ 90048 (wsgi:keystone--DFOREGROUND ├─ 90049) (wsgi:keystone--DFOREGROUND ├─ 90050 (wsgi:keystone--DFOREGROUND) ├─ 90051 (wsgi:keystone--DFOREGROUND ├─ 90052 (wsgi:keystone--DFOREGROUND ├─ 90053 (wsgi:keystone--DFOREGROUND ├─ 90054 (wsgi:keystone--DFOREGROUND ├─ 90055) (wsgi:keystone--DFOREGROUND ├─ 90056 (wsgi:keystone--DFOREGROUND ├─ 90057 / usr/sbin/httpd-DFOREGROUND ├─ 90058 / usr/) Sbin/httpd-DFOREGROUND ├─ 90059 / usr/sbin/httpd-DFOREGROUND ├─ 90061 / usr/sbin/httpd-DFOREGROUND ├─ 90156 / usr/sbin/httpd-DFOREGROUND ├─ 90157 / usr/sbin/httpd-DFOREGROUND ├─ 90158 / usr/sbin/httpd-DFOREGROUND ├─ 90260 / usr/sbin/httpd-DFOREGROUND ├─ 91346 / usr/sbin/httpd-DFOREGROUND └─ 91355 / usr/sbin/httpd-DFOREGROUNDOct 14 16:40:41 bdc2 python [90007]: Copying'/ usr/share/javascript/jquery_ui/ui/minified/i18n/jquery.ui.datepicker-af.min.js'Oct 14 16:40:41 bdc2 python [90007]: Copying'/ usr/share/javascript/jquery_ui/ui/minified/i18n/jquery.ui.datepicker-ja.min.js'Oct 14 16:40:41 bdc2 python [90007]: Copying'/ usr/share/ Javascript/jquery_ui/ui/minified/i18n/jquery.ui.datepicker-ar-DZ.min.js'Oct 14 16:40:41 bdc2 python [90007]: Copying'/ usr/share/javascript/jquery_ui/ui/minified/i18n/jquery.ui.datepicker-ky.min.js'Oct 14 16:40:41 bdc2 python [90007]: Copying'/ usr/share/javascript/jquery_ui/ui/minified/i18n/jquery.ui.datepicker-ar.min.js'Oct 14 16:40: 41 bdc2 python [90007]: Copying'/ usr/share/javascript/jquery_ui/ui/minified/i18n/jquery.ui.datepicker-lb.min.js'Oct 14 16:40:41 bdc2 python [90007]: Copying'/ usr/share/javascript/jquery_ui/ui/minified/i18n/jquery.ui.datepicker-az.min.js'Oct 14 16:40:41 bdc2 python [90007]: Copying'/ usr/share/javascript/jquery_ui/ui/minified/i18n/jquery.ui.datepicker- Lt.min.js'Oct 14 16:40:41 bdc2 python [90007]: Copying'/ usr/share/javascript/jquery_ui/ui/minified/i18n/jquery.ui.datepicker-be.min.js'Oct 14 16:40:52 bdc2 systemd [1]: Started The Apache HTTP Server. After reading this article, I believe you have a certain understanding of "what to do with python compress command not found errors when installing kilo version of openstack-dashboard". If you want to know more about it, you are welcome to follow the industry information channel. Thank you for your reading!