Network Security Internet Technology Development Database Servers Mobile Phone Android Software Apple Software Computer Software News IT Information

In addition to Weibo, there is also WeChat

Please pay attention

WeChat public account

Shulou

The method of Python misplaced keyboard, word length and letter rearrangement

2025-04-04 Update From: SLTechnology News&Howtos shulou NAV: SLTechnology News&Howtos > Development >

Share

Shulou(Shulou.com)06/01 Report--

Today, the editor will share with you the relevant knowledge of Python misplaced keyboard, word length, and letter rearrangement. The content is detailed and the logic is clear. I believe most people still know too much about this knowledge, so share this article for your reference. I hope you can get something after reading this article. Let's take a look at it.

Description of the misplaced keyboard problem

When we type, we often knock An into S and S into D by hand.

Now there is a programmer who typed a line of string by hand. Please rely on your smart brain to restore it (the order of characters on the keyboard: "`string []\ ASDFGHJKL;'ZXCVBNM,./").

Sample input: os, GOMR YPFSU/

Sample output: I AM FINE TODAY

Analysis of problems

The thought of this kind of problem is to replace characters, but it is very time-consuming and laborious to replace so many characters on a keyboard one by one, so we can arrange a subscript array to record the position of characters in the string. For unnecessary conversion, we might as well open the subscript array to 255 so that the ASCII value of each character can be directly used as the subscript of the subscript array to get its index in the original string.

Then according to the input, we can know that there is a space in the input, and there is no space in the given keyboard, so word segmentation is needed. There is a very simple method of word segmentation in Python. In C language, a character pointer array can be created to store each word in the same way as the average length of a word. You can look down first. After dividing the words, you can overlap the character pointer array. And then output in sequence. When outputting, first take the character as the index in the original string, and then take the index-1 to get the character from the original character. Note the format of the output.

Code implementation

The old rule is to run the results first:

The code is as follows:

Import syss=sys.stdin.readline (). Strip (). Split () indexarr= [0] * 25 stores all the data in an array and connects the two adjacent letters on the keyboard in the array as an index. Mystr= "`1234567890 color = QWERTYUIOP []\\ ASDFGHJKL;'ZXCVBNM,./" # stores the index of each letter. The data entered for later traversal uses for i in range (len (mystr)): indexarr [ord (mystrl [I])] = iflag=True# to traverse the entered n-segment string for line in s: if flag: flag=False for i in line: print (mystrr [indexarr [ord (I)]-1], end= ") else: print (") End= "") for i in line: print (mystr[ indexarr [ord (I)]-1], end= "") II. Average length of the word

If you do it in C language, count the spaces first, and add 1 to the number of words if the spaces are not followed by spaces.

If there is still a space traversing down after the space, add 1 to the number of letters if a position is not a space.

Finally, you have to add 1 to the number of words, because only one is counted at the beginning and end of the word cycle.

Problem description

Enter several words that contain only letters, each consisting of one or more spaces

The average length of the output word

Sample input: qwe qwe qwe

Sample output: 3.0

Analysis of problems

Segment the string, then calculate the length of each string, and then divide the length by the number of words.

Code implementation

The old rule is to run the results first:

The code is as follows:

Import sysnum=0n=0# here uses strip () to remove the newline character at the end of the input # and uses split () to segment the string. The final result is a list form mystr=sys.stdin.readline (). Strip (). Split () for i in mystr: num+=len (I) n+=1print (num/n) 3. Description of the letter rearrangement problem

Enter a dictionary (* at the end), and then enter several words. For each word w you enter, you need to find out in the dictionary all the words that can be rearranged with the letters of w and output them in one line in dictionary order from smallest to largest (if they do not exist, output: 0). Input words are separated by spaces or blank lines, and all input words are made up of no more than 6 lowercase letters. Note that the words in the dictionary are not necessarily arranged in dictionary order.

Sample input:

First line tarp given score refund only trap work earn course pepper part

Second line resco nfudre aptr sett oresuc

Sample output:

Course part refund score tarp trap

Analysis of problems

A dictionary is given, so when we look up the dictionary, we can first process the dictionary and then look up the words according to the standards of the dictionary.

Here we can first sort the dictionary to get a dictionary with the first letter in order, and then sort each element in the dictionary. Sort the substrings to be queried, then search through the ordered dictionary to find the direct output (that is, the standard dictionary is processed in a certain way, and then the words to be looked up are compared with the dictionary after the same transformation)

Code implementation

The old rule is to run the results first:

The code is as follows:

Import sys# meta-dictionary order string mydic=list (sys.stdin.readline (). Strip (). Split ()) mydic=sorted (mydic) words=sys.stdin.readline (). Strip (). Split () # the sorted string newdic= [] newwords= [] for i in mydic: # cannot be sorted directly, but can be converted to a dictionary first. Then sort newdic.append (".join (sorted (I) for i in words: newwords.append (" .join (sorted (I) flag=Falsei=0while I

Welcome to subscribe "Shulou Technology Information " to get latest news, interesting things and hot topics in the IT industry, and controls the hottest and latest Internet news, technology news and IT industry trends.

Views: 0

*The comments in the above article only represent the author's personal views and do not represent the views and positions of this website. If you have more insights, please feel free to contribute and share.

Share To

Development

Wechat

© 2024 shulou.com SLNews company. All rights reserved.

12
Report