Get the App
SLTechnology News&Howtos  ›  Network Security  › 

What is the solution to the error code 107 (err_ssl_protocol_error) SSL protocol error

Shulou Source: shulou.com Published: 2022-05-31 22:28:31 09月27日 Update

With regard to the solution to the error code 107 (err_ssl_protocol_error) SSL protocol error, I believe many inexperienced people do not know what to do. Therefore, this article summarizes the causes and solutions of the problem. Through this article, I hope you can solve this problem.

About the solution of error Code 107 (err_ssl_protocol_error) SSL Protocol error

There is a strange problem when Firefox browser accesses https://www.abc.com, reporting an error:

Ssl 107 (net::ERR_SSL_PROTOCOL_ERROR)

At first I thought ssl had failed, so I reinstalled it.

Installation process:

Step 1 # openssl genrsa-des3-out server1.key 1024

Generating RSA private key, 1024 bit long modulus

…… +

…… .. +

E is 65537 (0x10001)

Enter pass phrase for server1.key: set a password here

Verifying-Enter pass phrase for server1.key: re-enter a password

Step 2 # openssl req-new-key server1.key-out server1.csr

Enter pass phrase for server1.key:

You are about to be asked to enter information that will be incorporated

Into your certificate request.

What you are about to enter is what is called a Distinguished Name or a DN.

There are quite a few fields but you can leave some blank

For some fields there will be a default value

If you enter'., the field will be left blank.

--

Country Name (2 letter code) [GB]: CN

State or Province Name (full name) [Berkshire]: Beijing

Locality Name (eg, city) [Newbury]: Beijing

Organization Name (eg, company) [My Company Ltd]: xo

Organizational Unit Name (eg, section) []: xo

Common Name (eg, your name or your server's hostname) []: xo

Email Address []:

Please enter the following 'extra' attributes

To be sent with your certificate request

A challenge password []: enter here

An optional company name []: enter here

Step 3: # cp server1.key server1.key.org

Step 4: # openssl rsa-in server1.key.org-out server1.key

Enter pass phrase for server1.key.org: enter the password you just set here

Writing RSA key

Step 5:] # openssl x509-req-days 365-in server1.csr-signkey server1.key-out server1.crt

Signature ok

Subject=/C=CN/ST=Beijing/L=Beijing/O=xo/OU=xo/CN=xo

Getting Private key

After installing ssl, configure the nginx virtual host

Server

{

Listen 80

Server_name www.abc.com

Root / data0/htdocs/zhaolilei

Index index.html index.PHP

Rewrite ^ / https://www.abc.com permanent

Location. *\. (php | php5)? $

{

# fastcgi_pass unix:/tmp/php-cgi.sock

Fastcgi_pass 127.0.0.1:9000

Fastcgi_index index.php

Include fcgi.conf

}

Access_log / data1/logs/test1.log

}

Server

{

Listen 443

Server_name www.abc.com

Root / data0/htdocs/zhaolilei

Index index.html index.php

Ssl on

Ssl_certificate server.crt

Ssl_certificate_key server.key

Location. *\. (php | php5)? $

{

# fastcgi_pass unix:/tmp/php-cgi.sock

Fastcgi_pass 127.0.0.1:9000

Fastcgi_index index.php

Include fcgi.conf

}

Access_log / data1/logs/test.log

}

After the configuration, the access test still reported an error. Later, I checked more than N information on the Internet and did not have an explanation.

Calm down and think about it. It seems that only nginx version 1.2.1 has been upgraded recently. Does it have something to do with the version? some rules of the new version of nginx have been changed, such as: the log format should be defined on the virtual host, but no related problems have been found on the official website. I wonder if it has anything to do with the order of virtual hosts. I configure 80 first and then 443 here.

After testing, sure enough, put the virtual host of 443 on top of 80, restart nginx, and visit OK

After reading the above, do you know the solution to the error code 107 (err_ssl_protocol_error) SSL protocol error? If you want to learn more skills or want to know more about it, you are welcome to follow the industry information channel, thank you for reading!

Tags: Host virtual host problem configuration code solution error password above content method more version related test input weird helpless sure enough Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno Xiaomi MySQL NVidia Linux Apple