Get the App
SLTechnology News&Howtos  ›  Database  › 

Solution to mysql error number 1129

Shulou Source: shulou.com Published: 2022-06-01 04:36:54 10月04日 Update

SQLyog connection mysql error number 1129:

Mysql error 1129: Host 'bio.chip.org' is blocked because of many connection errors; unblock with' mysqladmin flush-hosts'.

Solution:

Cmd command line:

Mysqladmin flush-host-h 127.0.0.1-u root-p123456

Solve it.

Extended learning

Error: Host is blocked because of many connection errors; unblock with 'mysqladmin flush-hosts'

Reason:

Blocking caused by too many database connections interrupted by the same ip in a short period of time (exceeding the maximum of mysql database max_connection_errors)

Solution:

1. Increase the number of max_connection_errors allowed (address the symptoms but not the root of the problem):

① enters the Mysql database to view max_connection_errors: show variables like'% max_connection_errors%'

The number of max_connection_errors modified by ② is 1000: set global max_connect_errors = 1000

③ to check whether the modification is successful: show variables like'% max_connection_errors%'

2. Use the mysqladmin flush-hosts command to clean up the hosts file (I don't know in which directory mysqladmin can use the command to find: whereis mysqladmin)

① uses the command to modify the directory found: / usr/bin/mysqladmin flush-hosts-h292.168.1.1-P3308-uroot-prootpwd

Note:

The port number, user name and password can be added and modified as needed.

Those with master/slave master-slave database have to modify both the master database and the slave database (I only suffered from this loss and ended up with a few commands that were easy to lose).

The second step can also be done in the database with the following command: flush hosts

Most Baidu results are like this, but it still doesn't work for my database connection. After many verifications, it is found that the host address needs to be added, that is, execute the command mysqladmin flush-hosts-h 127.0.0.1-uroot-p

The above are the detailed methods and steps of this solution. Thank you for your support.

Tags: Command data database method error quantity directory result number no maximum success temporary cure master-slave host reason slogan address remarks password Apple Docker Huawei Linux macOS MariaDB Microsoft MySQL NVidia OPPO Reno Docker Shulou Information Microsoft Shulou Technology NVidia