Redis 3.0.7 installation and deployment
# #
Basic environment
OS: centos 6.6
DB: redis 3.0.7
# #
1. Download the source package, stable version
Http://redis.io/-- > Download it-- > download 3.0.7.
two。 Upload it to the server / usr/local directory and extract it
# cd / usr/local
# tar-zxvf redis-3.0.7.tar.gz
3. Compile
# cd redis-3.0.7
# make
# make test-can be omitted
4. Installation
# make install
5. Install database settings, you can set different ports, multiple instances
#. / utils/install_server.sh-- can be run multiple times
Welcome to the redis service installer
This script will help you easily set up a running redis server
Please select the redis port for this instance: [6379]
Selecting default: 6379
Please select the redis config file name [/ etc/redis/6379.conf]
Selected default-/ etc/redis/6379.conf
Please select the redis log file name [/ var/log/redis_6379.log]
Selected default-/ var/log/redis_6379.log
Please select the data directory for this instance [/ var/lib/redis/6379]
Selected default-/ var/lib/redis/6379
Please select the redis executable path [/ usr/local/bin/redis-server]
Selected config:
Port: 6379
Config file: / etc/redis/6379.conf
Log file: / var/log/redis_6379.log
Data dir: / var/lib/redis/6379
Executable: / usr/local/bin/redis-server
Cli Executable: / usr/local/bin/redis-cli
Is this ok? Then press ENTER to go on or Ctrl-C to abort.
Copied / tmp/6379.conf = > / etc/init.d/redis_6379
Installing service...
Successfully added to chkconfig!
Successfully added to runlevels 345!
Starting Redis server...
Installation successful!
6. Verification
# ps-ef | grep redis
# chkconfig-- list | grep redis
Redis_6379 0:off 1:off 2:on 3:on 4:on 5:on 6:off
# redis-cli-p 6379
127.0.0.1 purl 6379 > info
7. Start and stop
# service redis_6379 stop
# service redis_6379 start
8. Summary of questions:
1) install gcc and jemalloc
# yum-y install gcc
# rpm-ivh jemalloc-3.6.0-1.el6.x86_64.rpm
2) make Times has the following error, be sure to use jemalloc
Zmalloc.h:50:31: error: jemalloc/jemalloc.h: No such file or directory
Zmalloc.h:55:2: error: # error "Newer version of jemalloc required"
Make [1]: * * [adlist.o] Error 1
The reason is that jemalloc overloads the malloc and free functions of ANSI C under Linux. Solution: add parameters when make.
Solution:
# make MALLOC=libc
3) after make, a prompt appears
Hint: To run 'make test' is a good idea;)
But without testing, it can usually be used. If we run make test, we will have the following prompt
# make test
You need tcl 8.5 or newer in order to run the Redis test
Make: * * [test] Error_1
The solution is to install tcl8.5 with yum (or go to tcl's official website http://www.tcl.tk/ to download version 8.5 and refer to the official website for installation)
# yum install tcl
4) compiling test error report
* * [err]: Test replication partial resync: no backlog (diskless: no, reconnect: 1) in tests/integration/replication-psync.tcl
Expected condition'[s-1 sync_partial_err] > 0'to be true ([s-1 sync_partial_err] > 0)
Cleanup: may take some time... OK
Make [1]: * * [test] error 1
Make [1]: Leaving directory `/ usr/local/redis-3.0.7/src'
Make: * * [test] error 2
Solution:
The following errors may occur when executing make test on a slower machine, with no impact